Home/Support/Keyboards/Infinity ErgoDox/Flashing Ergodox Infinity
Flashing Ergodox Infinity 2017-01-11T03:23:44+00:00

Hello WhiteFox Forums Support Keyboards Infinity ErgoDox Flashing Ergodox Infinity

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Hallelujah98
    Participant
    Post count: 2
    #4390 |

    Hey,
    I successfully followed the instructions for installing drivers and my keyboard layouts to the Ergodox when I first got it. Now I need to go back and change my layout but I’m having some troubles.

    I should say I probably oringally went through the process on Windows 8 64bit and my HDD since died so this is a fresh install. I don’t have drivers installed from Zadig on this installation but the Ergodox has whatever default drivers Windows installed for it. I’m now on Windows 10.

    I put the Ergodox in flash mode but Kiibohd DFU Bootloader does not appear in Zadig. I’m guessing this is because there’s already drivers installed? I can see the Ergodox by checking ‘List all Devices’ and unchecking ‘Ignore Hubs.’ I’ve tried overwriting the drivers for the Ergodox through Zadig but that just made the keyboard unresponsive. I uninstalled the Zadig drivers through device manager and the keyboard is working again with default Windows drivers.

    No device is listed in kii-dfu. I tried running the command line version but it also doesn’t detect the Ergodox. I’m running everything as administrator.

    How do I flash it/upload layouts at this point?

    Thanks in advance.

    fuo213
    Participant
    Post count: 2

    Having this exact same issue. I don’t see the Kiibohd bootloader, and the keyboard switches between Ergodox keyboard and USB Input device depending on whether the flash button is pressed. Nothing listed in kii-dfu for me either 🙁

    parak
    Moderator
    Post count: 32

    The zadig drivers are only applicable to the bootloader, which the keyboard jumps to when the button on the back of the PCB is pressed (or key combo in configurator). Windows default drivers are used otherwise, and this part should not be modified.

    Basically, plugging the keyboard in, then pressing the button, and running ‘dfu-util -l’ in administrative mode should show a device. If it does, ‘dfu-util -D ‘ will flash the keyboard in lieu of the gui tool. If it doesn’t, you need to reinstall zadig drivers while it’s in bootloader mode.

    Hallelujah98
    Participant
    Post count: 2

    Thanks for the reply. I got it working. I was being dense. The device wasn’t going into flash mode at all. I probably didn’t include a flash button in my original layout. LCD was pink not red and I assumed this was flash mode. Worked flawlessly just using the flash button on the PCB. Thanks again.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.