Hello K-Type Forums Support KLL [help] Output/pjrcUSB/arm/usb_desc.c error

Tagged: ,

Viewing 1 post (of 1 total)
  • Author
    Posts
  • Alexis
    Participant
    Post count: 1
    #3378 |

    Hello,
    I am trying to compile firmware for new my new keyboard in order to use macros. I downloaded the The Kiibohd Controller off github, installed the Packages in the setup page and ran one of the convenient scripts to compile firmware just to test if it all works before adding my own kll files. I got an error though. After making sure everything was installed correctly as instructed on the wiki nothing changed. I then assumed there was a compatibility issue and tried it on first the latest version of Ubuntu and then 14.04.3 and still the same error. Due to this, I have come to the conclusion that I have made a really silly mistake, which I guess is understandable since I am almost a complete newbie to linux. Here is the build log (in this case with Arch):

    — Compiler Family:
    arm
    — Compiler Selected:
    gcc
    — Chip Selected:
    mk20dx128vlf5
    — Chip Family:
    mk20dx
    — CPU Selected:
    cortex-m4
    — Compiler Source Files:
    Lib/mk20dx.c;Lib/delay.c
    — Bootloader Type:
    dfu
    — The C compiler identification is GNU 6.1.1
    — Check for working C compiler: /usr/bin/arm-none-eabi-gcc
    — Check for working C compiler: /usr/bin/arm-none-eabi-gcc — works
    — Detecting C compiler ABI info
    — Detecting C compiler ABI info – done
    — Detecting C compile features
    — Detecting C compile features – done
    — Detected Scan Module Source Files:
    Scan/MatrixARM/matrix_scan.c;Scan/Infinity_60%/scan_loop.c
    — Detected Macro Module Source Files:
    Macro/PartialMap/macro.c;Macro/PartialMap/result.c;Macro/PartialMap/trigger.c
    — Detected Output Module Source Files:
    Output/pjrcUSB/output_com.c;Output/pjrcUSB/arm/usb_desc.c;Output/pjrcUSB/arm/usb_dev.c;Output/pjrcUSB/arm/usb_joystick.c;Output/pjrcUSB/arm/usb_keyboard.c;Output/pjrcUSB/arm/usb_mem.c;Output/pjrcUSB/arm/usb_mouse.c;Output/pjrcUSB/arm/usb_rawio.c;Output/pjrcUSB/arm/usb_serial.c
    — Detected Debug Module Source Files:
    Debug/cli/cli.c;Debug/led/led.c;Debug/print/print.c
    — Found Git: /usr/bin/git (found version “2.9.3”)
    — Found Ctags: /usr/bin/ctags (found version “5.8”)
    — Detected Layout Files:
    /home/alexis/Desktop/Test/Scan/MatrixARM/capabilities.kll
    /home/alexis/Desktop/Test/Macro/PartialMap/capabilities.kll
    /home/alexis/Desktop/Test/Output/pjrcUSB/capabilities.kll
    /home/alexis/Desktop/Test/Scan/Infinity_60%/scancode_map.kll
    /home/alexis/Desktop/Test/kll/layouts/md1Overlay.kll
    /home/alexis/Desktop/Test/kll/layouts/stdFuncMap.kll
    /home/alexis/Desktop/Test/kll/layouts/hhkbpro2.kll
    — Found DFU_SUFFIX: /usr/bin/dfu-suffix (found version “0.9”)
    — Configuring done
    — Generating done
    — Build files have been written to: /home/alexis/Desktop/Test/Keyboards/IC60.gcc
    [ 4%] Generating KLL Layout
    fatal: ambiguous argument ‘HEAD’: unknown revision or path not in the working tree.
    Use ‘–‘ to separate paths from revisions, like this:
    ‘git <command> [<revision>…] — [<file>…]’
    Scanning dependencies of target kiibohd.elf
    [ 8%] Building C object CMakeFiles/kiibohd.elf.dir/main.c.obj
    [ 13%] Building C object CMakeFiles/kiibohd.elf.dir/Lib/mk20dx.c.obj
    [ 17%] Building C object CMakeFiles/kiibohd.elf.dir/Lib/delay.c.obj
    [ 21%] Building C object CMakeFiles/kiibohd.elf.dir/Scan/MatrixARM/matrix_scan.c.obj
    [ 26%] Building C object CMakeFiles/kiibohd.elf.dir/Scan/Infinity_60%/scan_loop.c.obj
    [ 30%] Building C object CMakeFiles/kiibohd.elf.dir/Macro/PartialMap/macro.c.obj
    [ 34%] Building C object CMakeFiles/kiibohd.elf.dir/Macro/PartialMap/result.c.obj
    [ 39%] Building C object CMakeFiles/kiibohd.elf.dir/Macro/PartialMap/trigger.c.obj
    [ 43%] Building C object CMakeFiles/kiibohd.elf.dir/Output/pjrcUSB/output_com.c.obj
    [ 47%] Building C object CMakeFiles/kiibohd.elf.dir/Output/pjrcUSB/arm/usb_desc.c.obj
    /home/alexis/Desktop/Test/Output/pjrcUSB/arm/usb_desc.c:44:19: error: expected expression before ‘)’ token
    #define LSB(n) ((n) & 255)
    ^
    /home/alexis/Desktop/Test/Output/pjrcUSB/arm/usb_desc.c:63:2: note: in expansion of macro ‘LSB’
    LSB(BCD_VERSION), MSB(BCD_VERSION), // bcdDevice
    ^~~
    /home/alexis/Desktop/Test/Output/pjrcUSB/arm/usb_desc.c:45:20: error: expected expression before ‘)’ token
    #define MSB(n) (((n) >> 8) & 255)
    ^
    /home/alexis/Desktop/Test/Output/pjrcUSB/arm/usb_desc.c:63:20: note: in expansion of macro ‘MSB’
    LSB(BCD_VERSION), MSB(BCD_VERSION), // bcdDevice
    ^~~
    make[2]: *** [CMakeFiles/kiibohd.elf.dir/build.make:292: CMakeFiles/kiibohd.elf.dir/Output/pjrcUSB/arm/usb_desc.c.obj] Error 1
    make[1]: *** [CMakeFiles/Makefile2:100: CMakeFiles/kiibohd.elf.dir/all] Error 2
    make: *** [Makefile:84: all] Error 2
    Error in make. Exiting…

    Sorry to bother but no amount of googling has helped.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.