Hello K-Type Forums Support Keyboards Infinity ErgoDox Infinity ErgoDox Firmware Really Buggy

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • Tafryn
    Participant
    Post count: 2
    #4318 |

    Recent firmware binaries downloaded from the configurator seem to be really buggy. Modifier keys will get stuck, or simply stop working, keys will get stuck repeating while the rest of the keyboard fails to send key-presses, individual LEDs will stop working, etc. Most of these issues can be addressed by disconnecting and reconnecting the keyboard. However, that is only a temporary fix; the issues always return. Has there been a change to the firmware generated by the configurator in the last few months that may have caused this?

    gbarn
    Participant
    Post count: 6

    I am getting a similar result with fast typing it either locks up and I have to unplug and replug to clear or I get an infinite repeating key. All keys worrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr

    The above happened as I typed this. Got it on last Massdrop, in service only a month, I recently updated the key mapping via the online configurator. Help, it is somewhat unusable. It is getting worse the more I get use to it and the faster I type.

    Jeremy Bondeson
    Moderator
    Post count: 46

    @tafryn @gbarnabic

    Try to go to the alpha version of the configurator and import your previous .json file (should be in the zip you downloaded), then in the “kll defines” section add an entry for “MinDebouceTime” and set the value above 5 (maybe start at 7 and see if you need to go up/down from there). That configures the debounce settings for the keyboard. They are normally set at Cherry’s standard of 5ms, but you may be running into an issue with your switches.

    Could you also both just let me know which switches you have installed?

    gbarn
    Participant
    Post count: 6

    Ok, I did as instructed and am typing on it with this reply. I have the MinDedbouceTime set to 7 as suggested. I will give it a try and see if the issue goes away. I’ll report back in a few days. Thanks for the quick reply to the issue.

    Oh, I installed Cherry Browns for the switches.

    gbarn
    Participant
    Post count: 6

    It seemed to be working great for a week or so and it started happening again today. Keys getting stuck on repeat. It happens when I start to type really fast. This is very worrisome as I have a lot of money invested in it.

    Any other ideas or settings I should try? Is it possible that the changes I made to “fix” it have somehow been lost?

    gbarn
    Participant
    Post count: 6

    Ok I just flashed again using a 9 for the MinDebouceTime setting. I’ll try to uy

    I was typing the above message and had a typo and hit the backspace key very quickly to get rid of the y and the keyboard seemed to hang. I couldn’t get anything to type. I tried hitting the L1 and it seemed to enter that page, at least the LCD changed color but other keys didn’t work. Getting very frustrated at this point.

    gbarn
    Participant
    Post count: 6

    Keyboard is still locking up after a short time of use. What is the process I need to start to get it either resolved or sent back for a refund?

    PCallathan
    Participant
    Post count: 3

    I am having the same issues with the most recent ergodox. I also have an Infinity Ergodox from the second drop and it is running the same firmware and working flawlessly.

    – It is more likely the slave side that has the repeating key, but I have seen it on the master as well.
    – Multiple keys have issues (so far M, B, R, _, Backspace) which sort of rules out the switch hardware.
    – Interconnect between the master and slave can be removed during repeating and the slave key will continue to repeat.
    – Issue persists regardless which hand is the master (same firmware on both hands).
    – I have also seen when both halves will not send any keys to the PC but I can still change layers etc, so the keyboard is still functioning.

    I am compiling my own firmware and I have just grabbed the latest and changed the MinDebounceTime from 5 to 7. I will see if there is any improvement with that.

    gbarn
    Participant
    Post count: 6

    For the record I was able to return the keyboard and get my money back. I had spent a lot of time working the issue and came to the conclusion that it was never going to get resolved. I am and was a very good customer, and have spent plenty of dollars so the return was granted. @PCallathan good luck.

    parak
    Moderator
    Post count: 30

    Hey folks, sorry for the delayed response. This sounds like a known issue that will soon be fixed in the alpha configurator – I’ll post again as soon as it’s live there for you to try.

    parak
    Moderator
    Post count: 30

    Please update your firmware via the configurator – it’s currently running the latest fixes, some of which are relevant to a intermittent lockup of the keyboard.

    Rob
    Participant
    Post count: 13

    This issue sounds a little different, but I tried customizing my layer images from the controller git repository. Flashing one half was fine, but when I flashed the 2nd half, the slave couldn’t change layers consistently. The layer change keys were unreliable, either doing nothing or locking when they should have shifted. The left side display also only flashes, but doesn’t change color or show the layer icons.

    I tried fixing it by loading a new image downloaded from the configurator on February 17. It did clear my custom images, but the layer issue persisted. Today I flashed using a older image from February 12, and it resolved my issue. I’m wondering if the update referred to on February 13th or 15th has some bugs.

    Jeremy Bondeson
    Moderator
    Post count: 46

    Just a note here as well, the issue with the Ergodox Infinity slave is fixed and updated, so people would be encouraged to try the new version again.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.